Error on Interact with data

Hey! I am testing the new versions of the packages, setting up a node from scratch and running the Getting Started steps from the ComposeDB 4.x documentation, following it step by step, using the sample model. When interacting with the composite, the following error appears.

This is displayed in the console when I want to make a query from Yoga GraphiQL

ERR Error: HTTP request to 'http://localhost:7007/api/v0/collection' 
failed with status 'Internal Server Error': {"error":"Index for historical data on kjzl6hvfrbw6c5ajfmes842lu09vjxu5956e3xq0xk12gp2jcf9s90cagt2god9 is not available"}
    at RemoteIndexApi.fetchJson [as _fetchJson] (file:///home/ec2-user/.config/yarn/global/node_modules/@ceramicnetwork/common/lib/utils/http-utils.js:21:15)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async RemoteIndexApi.query (file:///home/ec2-user/.config/yarn/global/node_modules/@ceramicnetwork/http-client/lib/remote-index-api.js:17:26)
    at async queryConnection (file:///home/ec2-user/.config/yarn/global/node_modules/@composedb/runtime/dist/query.js:56:18)
    at async Object.queryConnection (file:///home/ec2-user/.config/yarn/global/node_modules/@composedb/runtime/dist/context.js:40:20)
    at async resolve (file:///home/ec2-user/.config/yarn/global/node_modules/@composedb/runtime/dist/schema.js:578:28)
    at async Promise.all (index 0)
    at async promiseForObject (file:///home/ec2-user/.config/yarn/global/node_modules/@graphql-tools/executor/esm/execution/promiseForObject.js:11:28)
    at async file:///home/ec2-user/.config/yarn/global/node_modules/@envelop/core/esm/orchestrator.js:373:27
    at async YogaServer.getResultForParams (file:///home/ec2-user/.config/yarn/global/node_modules/graphql-yoga/esm/server.js:285:26) {
  path: [ 'simpleProfileIndex' ],
  locations: [ { line: 2, column: 3 } ],
  extensions: [Object: null prototype] {}

When a model is newly added to the node to be indexed we kick off a historical sync to sync all existing data in that Model. By default, we don’t allow queries against that model until the historical sync completes.
The current release candidate doesn’t yet enable historical sync by default though, so it’s in this weird state right now where the default behavior doesn’t really make sense as it won’t allow queries until the historical sync completes, but it also doesn’t run the historical sync by default. So there are two options: 1) turn on historical sync by setting the CERAMIC_ENABLE_EXPERIMENTAL_SYNC env var to true, then waiting for the sync to complete (status of the sync will be logged once a minute to the Ceramic logs) or 2) allow queries to run even without historical data by setting the allow-queries-before-historical-sync flag in the ceramic config file to true. This wouldn’t be recommended in production, but for testing purposes it should be fine to unblock your development.

Sorry for the confusion here! The default behaviors will make more sense once historical sync is enabled by default in the next release.