Error starting up create-ceramic-app

This seems to happen intermittently when booting up the create-ceramic-app via “npm run dev”, and it doesn’t appear my data is being saved to ComposeDB when it does run. Any ideas here?

[Ceramic] [2023-02-09T03:27:07.530Z] WARNING: Warning: indexing and query APIs are experimental and still under active development.  Please do not create Composites, Models, or ModelInstanceDocument streams, or use any of the new GraphQL query APIs on mainnet until they are officially released
⠧ [Ceramic] Starting Ceramic node
[Ceramic] [2023-02-09T03:27:08.342Z] WARNING: Can not connect to /dns4/

[Ceramic] [2023-02-09T03:27:08.343Z] WARNING: HTTPError: connect QmSqeKpCYW89XrHHxtEQEWXmznp6o336jzwvdodbrGeLTk failure: failed to dial QmSqeKpCYW89XrHHxtEQEWXmznp6o336jzwvdodbrGeLTk:
  * [/ip4/] websocket: bad handshake
  * [/dns4/] websocket: bad handshake
⠙ [Ceramic] Starting Ceramic node
[Ceramic] [2023-02-09T03:27:11.107Z] IMPORTANT: Connected to anchor service '' with supported anchor chains ['eip155:100']
✖ [Ceramic] Ceramic node failed to start with error:
✖ [Ceramic] 
      return callback(new OpenError(err))

Wondering if my ISP is blocking this again or something, but manifesting differently this time.

So I also spun up a brand to create-ceramic-app, seemed to start up properly, but then got this error:

this is what is on the command line:

[2023-02-09T03:43:49.061Z] WARNING: Error loading stream kjzl6cwe1jw145cjbeko9kil8g9bxszjhyde21ob8epxuxkaon1izyqsu8wgcic at time undefined as part of a multiQuery request: Error: Timeout after 7000ms

I am using Node v 16.16.0

trying now gives this (just signing via Metamask as I normally have been)

@sterahi tagging you in

That last message usually means that the Ceramic node is having some problems. I’d suggest deleting all of your generated definitions (from src/__generated__) & trying again. If the problem persists open up your dev console & delete the did entry in the application tab. It might just want you to reauthenticate.

yeah, I’ve deleted the DID and re-signed in. Even decoded the JWT which shows the correct address i’ve signed the login message. I’ve also cloned a new instance of the example app. Do I need to delete all of the .ceramic stuff in my home dir too?

Your .ceramic in your home directory shouldn’t be a problem, but just to confirm I’d make a backup of it (just copy the folder & rename it something like .ceramic.bak and try again.

Hmm, Ive redone that as well and still get this error with bad signature. Very lost.

Just for my own sanity, was the install ever working properly? Were you able to store any data in ComposeDB from the get go? Can you try updating to node 16.19.0 to confirm that the problem is not node?

To try & break down the errors you’ve been seeing:
The first error happens occasionally if the node did not shut down properly, usually running killall node && killall ipfs sorts it out.
The second error happens if the data persistence isn’t available. I see it often when I’m killing ceramic processes.
The third error could be from a few different areas, it could be caused from using a mismatched admin did key pair, or it’s possible that your code is trying to update a stream that does not belong to the DID that’s the stream controller.

Haha, I feel your first question :slight_smile: - yes, this worked fine right out of the gate (see some of my previous posts). I can try on a new PC as well just to take it even further, but i’ve gone as far as removing my .ceramic folder, and re-cloning the instance. I guess I will ensure i’ve rebooted my machine as well for sanity.

Hmm, i tried on a old PC, which I had recently formatted the HD. Didn’t seem to work out of the box. Is there any NPM requirements for this or does this assume people have followed the ComposeDB setup prior to running this example?

The only external dependency that we don’t preinstall with CCA is node-pre-gyp that & I don’t think that we’ve migrated to the new version of ipfs so anything beyond I think node 18 throws errors, I suggest using Node 16.19.0 because I know that version works great.

Hey @walletchat were you able to get this working or is it still an issue for you?

I will try it again soon, after trying 3-4 times it was really odd. I figured it was best to wait until all your changes and forks are done to spend more time on it.

1 Like

sounds good. There will be a new release of both the Ceramic and ComposeDB packages early this week which will be the official release versions for ComposeDB Beta, so those should hopefully serve as a good stable set of package versions to try again with.

1 Like