Failed to start ceramic node with ceramic daemon

I want to try out the CLI and I was using the following 2 guides:

Based on these I did the following steps on Ubuntu 22.04.1:

  1. Install node, npm, nvm
  2. Install node v14 (npm v6 ← this is automatic ofc)
  3. npm install -g @ceramicnetwork/cli
  4. ceramic daemon

I got the following error:
Error message:
const CustomEvent = globalThis.CustomEvent || Event

ReferenceError: Event is not defined
at Object. (/home/ubuntu/.nvm/versions/node/v14.21.2/lib/node_modules/@ceramicnetwork/cli/node_modules/it-parallel/index.js:15:47)
at Module._compile (internal/modules/cjs/loader.js:1085:14)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1114:10)
at Module.load (internal/modules/cjs/loader.js:950:32)
at Function.Module._load (internal/modules/cjs/loader.js:790:12)
at ModuleWrap. (internal/modules/esm/translators.js:203:29)
at (internal/modules/esm/module_job.js:183:25)
at async Loader.import (internal/modules/esm/loader.js:178:24)
at async file:///home/ubuntu/.nvm/versions/node/v14.21.2/lib/node_modules/@ceramicnetwork/cli/bin/ceramic.js:3:1

What is the solution for this?

Hey @mdot, thanks for the post.

Those docs are slightly outdated. Can you please upgrade to Node v16?

thanks, that worked. Which docs should I use moving forward to avoid problems like this?

OK, good to know that it worked.

Let me double check with the team and get back to you about the latest docs.

Hey @mdot, you were looking at the latest docs, they just needed to be updated. Fixed now!

Please don’t hesitate to report any other issues you find, we’d really appreciate it!

1 Like