Getting a 504 when connecting to 3ID

Unable to connect to 3ID, this has been working for awhile. It seems to be an issue when there is no cached information in the browser.

Request: GET


HTTP/2 504 Gateway Timeout
content-type: application/json
content-length: 41
date: Tue, 27 Sep 2022 08:05:23 GMT
x-amzn-requestid: 39ae40cc-028d-45ca-a423-70ff030d0bca
x-amzn-errortype: InternalServerErrorException
x-amz-apigw-id: ZHA6DHXmPHcFtkw=
x-cache: Error from cloudfront
via: 1.1 (CloudFront)
x-amz-cf-pop: YUL62-C2
x-amz-cf-id: 8EMm03eg0_7t1XV6uv5bkwpK5mFPlBjjA89w-tv9qxTqoWeHyEdS4g==
X-Firefox-Spdy: h2

Hi @bengobeil, welcome to our forum!

We’ve been slowly phasing out the older 3ID connect model since it has performance, usability, and security issues (with key revocation, etc.)

Can you describe your use case a bit? I can try to recommend what to use instead. Apologies for the trouble :frowning:

We store contact information using Self Id / 3ID connect / JWE encryption.

So it is discontinued?

We are recommending moving away from 3ID in favor of did-session utilizing did:pkh as the primary DID method, but 3ID has not been discontinued yet.

Having said that, the domain seems to have been down for a while. Has it been a while since you last tried it?

Not sure, it works if a user has already connected to 3ID and still has cached info in browser, it could have been a week since it hasn’t worked.

Oh, ok :frowning: I’m trying to figure out what happened so that I can recommend something going forward.

Looks like this was very old infra that might have accidentally been deleted :confounded:

We did just make an update to js-3id that you should be able to run against the current Ceramic network though.

Having said that, I would still strongly recommend looking at did:pkh and CACAO as the way forward.

FYI it now works without upgrading to the new package version.

You must have fixed the infra issue. We will upgrade the package version and look at your suggestions for the way forward.



Oh, cool, good to hear!

1 Like