Graphql:schema GraphQL version error

Hi I am trying to write and read a composedb composite. I have a composite schema definition, use it to create a model, and deploy it. Now that I want to interact with it (e.g. run composedb graphql:schema), I get error:

Cannot use GraphQLScalarType “Int” from another module or realm.
Ensure that there is only one instance of “graphql” in the node_modules

I found past question Cannot use GraphQLScalarType "String" from another module or realm - #6 by mkc which shows how to solve this (reinstall everything with pnpm) but the approach is not working for me.

I tried to uninstall all npm modules, delete node_modules, and reinstall them all (cli, daemon, devtools, graphql) from scatch and restart the daemon, but keep getting error/warning with

└─┬ @composedb/devtools-node 0.3.1
└─┬ express-graphql 0.12.0
└── ✕ unmet peer graphql@“^14.7.0 || ^15.3.0”: found 16.6.0

My goal is to make sure the composedb daemon and composedb graphql:schema are using the same GraphQL version or instance but between npm/pnpm/cli/daemon/graphql/compiled schema I am missing something

@paul any ideas here?

The warning can be safely ignored as express-graphql works with graphql v16, the only constraint is having the package manager setup ensure only one version of the graphql dependency is used.