My First Composite Walk-Thru Errors

I am following the walk-through here at: Your first composite | ComposeDB on Ceramic

First step to download the .json from Claynet does not work (but the doc says there may be issues, so I downloaded the .json manually as it describes).

composeDBdemo % composedb graphql:server --ceramic-url=http://localhost:7007 --graphiql --port=5001 my-first-composite.json
āœ– Cannot convert undefined or null to object

moving on to the next step I run:

composedb composite:deploy my-first-composite.json --ceramic-url=http://localhost:7007
āœ– Cannot read properties of undefined (reading 'createJWS')

Is there a verbose mode or something that can be used to understand more of what I am doing wrong?

1 Like

Sorry I guess maybe I was missing a private key there based on other forum posts I have read now.

I still cannot get past this error though:

>>> composedb composite:deploy my-first-composite.json --ceramic-url=http://localhost:7007
āœ– AbortController is not defined

node version was wrong. Solved

@walletchat I was just curious, what node version and NPM version did you need to switch to? Iā€™m having a similar issue that seems to be related to node versioning

Now using node v16.16.0 (npm v8.11.0)

I actually ended up using pnpm - I had permission issues with the -g / global installs with npm.

1 Like