Problem on creating a stream


I had a trouble running a command on CLI with glaze, it’s the Create a Stream step (4) with glaze, in the CLI guide. For now, any input I pass to tile creation, strangely, I am receiving

SyntaxError: Non-base16 character with the example command in the guide pasted.

here’s that error :

$ glaze tile:create --key MY_KEY --content '{"stageName":"streamerd"}'
  SyntaxError: Non-base16 character

just checked there was another question, getting the same error while creating a schema. Well I am not at that phase yet.

And wondering if there’s been an update and my CLI version also needs an update.
got this setup.
@glazed/cli/0.2.2 darwin-x64 node-v16.14.0

Have a nice time,
here’s the guide I was following.

FYI @paul, can you take a look please?

The key provided with the --key flag must be a base16-encoded private key, the error means the value you’re providing is not base16-encoded.

1 Like

:wave: I faced this same issue and my confusion was in the documentation the example mentions the use of --key option, though the terminal output when running glaze did:create is

✔ Created DID did:key:xxxxxxxx with seed xxxxxxxxx

So perhaps just mentioning in the Docs that you need to use the seed value here, not the key value might help as that also tripped me up until I saw this post. :smiley:

This is already indicated in the section regarding the creation of the key, right below the key creation output: Getting started with the CLI - Ceramic Developers

1 Like

Hi, I noticed the same issue when following the documentation in ComposeDB…

where the instructions to generate a key are simply:
composedb did:generate-private-key

but it causes error later in the process when attempting to create models with did since it requires non-base16 encoding and the key generated from the given command doesn’t meet that requirement.

Solution suggested in this thread worked for me using the did:key and seed from the below commands:
npm install --global @glazed/cli
glaze did:create

I was thinking to create a fork of composeDB documentation and add the above commands but just wanted to first share here before proposing to update the document :slight_smile:


Note the Glaze CLI is deprecated and not recommended for use anymore. @paul any idea why the DID generated from composedb did:generate-private-key didn’t work but the one from glaze did:create did?

Could it be…

composedb did:generate-private-key

doesn’t return non-base16 which is what is being expected during the composite creation step?

The did:generate-private-key encodes the key in base 16 before logging it so I suppose there’s another issue here?