Problem on running 'ceramic daemon'

Hi guys hope you are doing fine .
I have an issue on running ceramic daemon command. this is the error that I’m getting :

I installed @ceramicnetwork/cli package and the package is fine.
Thanks for your time , I appreciate your answer.

Hey @Ali.hsz do you have any configurations added to your daemon config file? If yes, can you show me the anchor configuration you have there?

Hi @Ali.hsz,

What version of the CLI are you using?

Hey , No I didn’t add anything to the default configuration.

It’s the default version , it must be the latest.

OK, I think your anchor configuration is correct (it’s the default).

Can you please try again with --network testnet-clay added to your CLI command?

The error is a bit changed but it’s still there.

Oh, that’s a different error. We were undergoing some maintenance recently so that might explain it - you should not get ECONNREFUSED errors connecting to the Clay CAS node.

Are you getting this error repeatedly?

Hi, Julian again :slight_smile: haha
Yesterday it was working and now I’m getting this same error but I’m not getting the deadlines exceeded nor connection refused, just the ECONNREFUSED.

julianperassi@DESKTOP-8NL0MS3:~/brand/my-app$ ceramic daemon --network testnet-clay
(node:8054) ExperimentalWarning: The Fetch API is an experimental feature. This feature could change at any time
(Use `node --trace-warnings ...` to show where the warning was created)
Ceramic daemon failed to start up:
TypeError: fetch failed
    at Object.processResponse (node:internal/deps/undici/undici:6323:34)
    at node:internal/deps/undici/undici:6648:42
    at node:internal/process/task_queues:140:7
    at AsyncResource.runInAsyncScope (node:async_hooks:203:9)
    at AsyncResource.runMicrotask (node:internal/process/task_queues:137:8)
    at process.processTicksAndRejections (node:internal/process/task_queues:95:5) {
  cause: Error: connect ECONNREFUSED
      at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1300:16) {
    errno: -111,
    code: 'ECONNREFUSED',
    syscall: 'connect',
    address: '',
    port: 5011

I ran it again and now I’m getting a different one, but as you can see most of the connections are refused. :slight_smile:

[2022-09-08T05:36:43.746Z] IMPORTANT: Connecting to ceramic network 'testnet-clay' using pubsub topic '/ceramic/testnet-clay'
[2022-09-08T05:37:16.588Z] WARNING: Can not connect to /dns4/
[2022-09-08T05:37:16.588Z] WARNING: HTTPError: connect QmQotCKxiMWt935TyCBFTN23jaivxwrZ3uD58wNxeg5npi failure: failed to dial QmQotCKxiMWt935TyCBFTN23jaivxwrZ3uD58wNxeg5npi:
  * [/ip4/] dial tcp4 connect: connection refused
  * [/ip4/] malformed HTTP response "\x13/multistream/1.0.0"
  * [/ip4/] dial tcp4> i/o timeout
  * [/ip4/] dial tcp connect: connection refused
  * [/ip4/] dial tcp connect: connection refused
  * [/ip4/] dial tcp connect: connection refused
[2022-09-08T05:38:02.185Z] WARNING: Can not connect to /dns4/
[2022-09-08T05:38:02.185Z] WARNING: HTTPError: connect QmbeBTzSccH8xYottaYeyVX8QsKyox1ExfRx7T1iBqRyCd failure: failed to dial QmbeBTzSccH8xYottaYeyVX8QsKyox1ExfRx7T1iBqRyCd:
  * [/ip4/] dial tcp connect: connection refused
  * [/ip4/] dial tcp connect: connection refused
[2022-09-08T05:38:22.265Z] IMPORTANT: Closing Ceramic instance
[2022-09-08T05:38:22.269Z] IMPORTANT: Ceramic instance closed successfully
Ceramic daemon failed to start up:
FetchError: request to failed, reason: getaddrinfo EAI_AGAIN
    at ClientRequest.<anonymous> (/usr/local/lib/node_modules/@ceramicnetwork/cli/node_modules/node-fetch/lib/index.js:1491:11)
    at ClientRequest.emit (node:events:513:28)
    at ClientRequest.emit (node:domain:489:12)
    at TLSSocket.socketErrorListener (node:_http_client:494:9)
    at TLSSocket.emit (node:events:513:28)
    at TLSSocket.emit (node:domain:489:12)
    at emitErrorNT (node:internal/streams/destroy:151:8)
    at emitErrorCloseNT (node:internal/streams/destroy:116:3)
    at process.processTicksAndRejections (node:internal/process/task_queues:82:21) {
  type: 'system',
  errno: 'EAI_AGAIN',
  code: 'EAI_AGAIN'

This is very strange. Are you unable to bring your daemon up at all, or does this happen intermittently?

Yes that’s strange , actually this is the first time that I’m trying to build on ceramic and I want to test different features to see how exactly ceramic data models work , but unfortunately I couldn’t accomplish that yet .

Yeah :sob:

So, it does happen every time you start the daemon? Or sometimes?

it happens every time , I couldn’t manage to start the daemon yet.

Are you certain there’s no networking issue on your end? A firewall or something like that?

Where are you trying to run the daemon?