Failed to resolve uint8arrays

I can’t seem to get past this when upgrading things, installing new versions. Have tried deleting cache/node_modules and reinstalling everything. Also tried installing uint8arrays directly to no avail. Any ideas?
image

deleting the uint8arrays import in that file allows it to build - but not ideal solution…

Is from trying to use did-session? and what version of cacao/did-session? (does look like latest)

Also your node version?

correct - believe it was installed from did-session, node v16.16.0

thanks, which ceramic related library are you interacting with directly? (selfid?) and using with an eth account?

Not interacting with any at this point as I can’t get it to build because of that error :slight_smile: I was in the progress of upgrading from the old IDX toolset and 1.5(ish) versions of the packages I had installed. Trying to use the following:
@ceramicnetwork/http-client - 2.13.0
@ceramicnetwork/stream-tile - 2.12.0
@glazed/devtools 0.2.0
@glazed/did-datastore 0.3.2
dids 3.4.0
key-did-provider-ed25519 2.0.1
key-did-resolver 2.3.0

Not using Eth accounts - working with the dids directly.

ok, so not using did-session or selfid, this is just failing on install? I cant really tell at which point you are ending up the dependency that is causing the error here

So all those modules install fine with no issues. Do the yarn add for each and all good. Immediately after, I try to run the build command for the app and that error shows up. If I go in and delete that unit8array line in the module code, then rerun the build command it works fine/finishes.

Hopefully that makes it more clear.

oh ok, hmm difficult to say, on thing i noticed is the version differs for uint8array in that package, maybe the package manager is not installing both versions

maybe trying forcing it to resolve the same version (dont think downgrading would cause any other issues), for yarn you could add it to resolutions in your package.json

If it does work, it may not be the best solution, but difficult to replicate without anyone else reporting, and we should probably update version in other libs.

"resolutions": {
  "@didtools/cacao/uint8arrays": "^3.0.0”
}

Unfortunately, didn’t work, but using following did - hopefully won’t cause any side effects:

"resolutions": {
    "uint8arrays": "^3.0.0"
}

My yarn.lock is showing four different versions of uint8array:

  • most of the ceramic packages - ^3.0.0
  • @didtools/cacao@^1.0.0 - ^4.0.2
  • @didtools/pkh-solana@^0.0.1 - ^3.1.0
  • nist-weirstrauss ^1.3.0 (dependency of key-did-resolver ) - ^2.1.4
1 Like

Ok, yeah in your setup you wont be relying on the @didtools/cacao library, should be no issue and would be obvious otherwise i think. Would be nice to find root cause, but will likely wait to see if anyone else reports before revisiting.

2 Likes